Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
eVic VTC Dual very rarely doesn’t fire - broken or normal?
(11-06-2016, 10:23 AM)CryptoWyrm Wrote:  
(11-06-2016, 09:28 AM)gfdeputy2 Wrote:  hope you get it taken care of. Although I have given all my joyetech mods away to new Vapers every one works flawlessly still
I just was returned my very first mod my Joyetech VT. The person I gave it to upgraded to the cuboid. I will not be giving the VT away again It is staying with me as it is the device that got me to quit smoking!

Thanks, and congratulations on quitting smoking 微笑 I'm not fully there yet, but the Ultimo tank worked much better for me than the smaller e-cigarettes I tried before, looks like I need the extreme amount of vapor, so I hope this time I manage to stay away from cigarettes completely. I tried it loads of times over the years, started with the original ego and the 510, then lots of different ego models that came out over the years. I mostly bought Joyetech devices, but also got one from Kangertech, one from Innokin and two from Eleaf. But those all never managed to get me away from cigarettes.

The Ultimo is really the first atomizer where I can see it working, where I can easily go for hours at a time without even wanting a cigarette. I'll try getting the TFV8 baby beast too. Would get the new Joyetech Ornate but that is too big (25mm) for the VTC dual it seems. Although if I understand it correctly it would work, it would just look weird? Don't really care about how it looks as long as it works.
A lot of people like the TFV line I did not care for them I owned a couple of them, got rid of them both I now have a freemax starre Pure & a Ijoy Limitless XL & love them both will be trying the ultimo soon & possibly the Ornate

Just received a new VTC Dual, the shop I bought from sent me a new device right away and it arrived the next day, and they even sent it before I have to send back the old one so I didn't have to go back to cigarettes during the return, which is really great, made the exchange as painless as possible for me.

The new device has three differences I noticed immediately, thought I'd post that here for future reference, if someone else should run into the same problem.

First of all, the battery cover and the device didn't fit perfectly on the old device. One edge of the battery cover was maybe a millimeter higher than the device. I thought that was normal because I've read in a few reviews that people were nitpicking about that (it's barely visible). This new device however doesn't have that, the cover fits perfectly. Maybe this one millimeter difference kept the 510 from having a perfect connection since the tank sits atop the place where the device and the battery cover connects.

The second thing I noticed is that the fire button feels a tiny bit different. Less loose. So it could also really have been the fire button that was the issue.

The third and last difference I noticed is the battery door on the dual battery cover. On the new device it seems to fit better. You only notice it when you put the device down since the difference is so tiny that you can't see it, the old one would feel as if the battery cover got pushed up a tiny bit, as if it didn't fit snugly, while the new one seems to just fit perfectly. This could also have made a weak connection I guess that resulted in the issue I was having.

All in all these differences are all extremely tiny, barely noticeable, so maybe none of them were responsible for the issue, or it could have been any of them. So far everything works great with the new device, but I'll have to see how it fares after a few days since the issue I had didn't happen every day. But so far so good 微笑
Glad you got it replaced & didn't have to smoke any stinkies!

Definitely not normal.. Mine seems to be pretty flawless.. . I test devices for several companies and put mine through the same punishment and the only flaw I found seems to be the paint is fairly easy to chip...
(11-02-2016, 10:39 AM)CryptoWyrm Wrote:  I’ve been using the eVic VTC Dual with the Ultimo tank for a little over three weeks now and while it is an amazing device I absolutely love, there is one annoying thing happening that I fear might mean my device is broken, would be great if someone else who owns the VTC Dual can tell me if he noticed this as well or if this is only happening with my device, meaning that I should return it before it gets worse.

Sometimes when I press the fire button, the device doesn’t fire. No error message, the screen turns on, but it doesn’t fire, there is no vapor. It only starts working on the third or fourth try and then it keeps working perfectly for hours or usually days. Sometimes, the counter that tells you how many seconds your current puff lasted resets a few times during the puff, as if I had let go and pressed the fire button rapidly a few times during the puff. These two things happened extremely rarely so far, in this 3+ weeks of all day use I have only noticed it about a dozen times. So far it has only happened right after I changed the batteries or when the device has been standing without me using it for 30 minutes or so. Could be that I just missed it at other times of course, but I tend to look at the display after nearly every vape and then I would have seen if it would have only shown a puff for 0.4 seconds or something similarly short.

Could this be one of the protection circuits kicking in for some perfectly normal reason, despite there being no error message shown on the display, or is my device broken? This is my first "box mod" type e-cigarette, so I am a newbie at this.

Additional info that might be useful:

I’m using two sets of batteries, both pairs are married, brand new, one pair is Sony VTC5 and the other pair is Sony VTC5a, charged externally with an Xtar VC2 charger. I’m using 70/30 VG/PG juice, the issue occurred on both the ceramic and the clapton coil that came with the kit. I vape in wattage/power mode at 70 watts and I haven’t updated the firmware yet.

I found your post after google searching this issue. I have had my dual (bought from 3f) for about a week and it has been doing this too. not exactly rarely but maybe 3 times out of ten it will fire to .3 seconds like 3 times in a row(onlyu way I know how long) if I continue to hold the fire button when it does this it just goes back to defualt screen as if I never fired it. I was worried it was a defect but after reading some of this thread I cleaned the 510 on both the atty and the device. currently using moonshot 22mm. No misfires yet. but I only vaped briefly. I'll reply again in a day if I see no misfired then its most definitely a dirty contact. and then we'll know this thing is finicky about dirt.  btw, I bought this thing because I have had a vtc Mini for over a year now, used and kinda abused but works flawlessly so I was a bit bummed to see this thing not working flawlessly from the get go.

THanks for starting this discussion.

Attached Files Thumbnail(s)
So after cleaning the 510 on both the atty and the device I have had no misfiring after a day and a half. I think it was either dirty from the manufacturer or I screwed on very dirty atty threads. I'll come back and reply again if it starts this behavior for no reason. thanks!!
I always wipe the threads of my atty's & Mod before installing
I spray down my mod 510 with electrical contact cleaner weekly
once every month or two I disassemble mods & clean inside with contact cleaner every mod I own or have owned are still going strong



Forum Jump:

Users browsing this thread: 1 Guest(s)