Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
eVic Series eVic VTC Dual Atomizer Short circuit problem?
Hi i bought this eVic VTC Dual few weeks ago and im getting constantly this Atomizer Short circuit error anyone know how to fix this?

it comes just random i get pass it by screwing the atomizer off and screw it back again.

im still using these old Kraken Genesis atomizers i don't have any problems using them with my eVic VTC Mini 60W.

im using:
-Panasonic NCR18650B Rechargeable 3400mAh 3.7V 18650 Li-ion Batteries
-Kanthal 30mm
-Mesh 400
Have you ever tried other tanks?
I agree with Kermit I have had mods that don't like certain atomizers
they work fine with some & not well with others
try a different atomizer to test

Thanks for advice i tried with authentic Griffin and it won't short...
These Krakens which i have are clones so it might have something to do with it.... but its bit strange cus they work well in eVic mini.
I believe the 510 connector is different on the dual than the VTC. measure the 510 threads on both attys & see if there is a difference in length

Had the same issue, I removed the atomizer from the tank and found the connection to the mod was wet. Remove yours and make sure everything is dry
~Detroit, Michigan~
-Yea i would say there's 2 thread difference Griffin has 7 threads and Kraken 5 if i count these right... length is same 4mm... and boht bot pins can be moved Griffin is gold plated...

-No connections aren't wet...

I end up trying this and i check with multimeter that there's no short on Kraken... but it didn't help... although it fix one of my kraken i have 5 of these and they all short on eVic VTC Dual...

eVic VTC Dual gives Kraken dual coil readings 0.35Ω - 3.20Ω

eVic VTC Mini shows steady 0.32Ω - 0.34Ω
eVic VTC Dual gives Griffin dual coil readings 0.46Ω - 0.48Ω

eVic VTC Mini gives 0.44Ω - 0.46Ω
Hey dude. I'm having the same issue, but i'm using a Limitless XL. Have you found any solutions for that?
I do not have that issue with any of my tanks including the Limitless XL not sure what is going on with your duals

I have the same issue, I use limitless RDTA Classic and I realize it always happen when the battery is 50% or lower and when it happens it changes the power from 70w to 20 and the coil say it 1,59 ohms or more but my coil is 0,45 ohms.
Any one can help me.


Forum Jump:

Users browsing this thread: 1 Guest(s)