Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
eGrip eGrip battery doesn't get charged
#1
Hello,

the battery of my eGrip doesn't get charged anymore (after about 6 months usage).

I've checked the cable as well as the charger, both work with other devices without problems.

After pluging in the cable to the eGrip the battery symbol starts to flash, and that remains
for hours. Even after 10 hours, when I push the start button, I still get the message "battery low".

Any suggestions?

Thanks in advance.

Roger (from Austria)
Reply
#2
Sorry you're having problems. I don't have this device but does it have a reset button in the bottom of the device? I'd try that, but you have to admit it is still more economical and safer to vape than smoking even if your battery is bad and you have to replace it. Stick around here someone will help you figure out the problem I suspect.
Reply
#3
From remote and without any detail knowledge, ff you are a chain vaper it might be the battery being simply flat after 6 months.
Reply
#4
Kindly please email to service@joyetech.com. They'll look into it.
Reply
#5
(09-02-2016, 03:42 PM)RogerAT Wrote:  Hello,

the battery of my eGrip doesn't get charged anymore (after about 6 months usage).

I've checked the cable as well as the charger, both work with other devices without problems.

After pluging in the cable to the eGrip the battery symbol starts to flash, and that remains
for hours. Even after 10 hours, when I push the start button, I still get the message "battery low".

Any suggestions?

Thanks in advance.

Roger (from Austria)


Hi Roger;

This problem is solved?

Same problem my EcoVit.

I wait for answer.

Thanks in advance.

Serkan ( From Turkey)
Reply


Bookmarks

Forum Jump:


Users browsing this thread: 1 Guest(s)