Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Repairing the Joyetech Cuboid atomiser short error.
#1
Hello everyone.

I have a cuboid in my collection, and my fiancee loved it due to its small size so also purchased one.

It worked fine for a long time, but now has the dreaded atomiser short error-this is with any of my 40+ tanks or RDA's that work perfectly on my devices.

The device is out of warranty, so I will need to fix this myself-I have done this previously with other mods with different issues, and enjoy tinkering, so I do not mind having to do this.

My main question is, will it be as simple as raising the 510 back up, or will I need to do more work to get the device working again?

It is her only dual 18650 device, so it would be nice to get it working again, as it was/is well used and loved.

Thanks everyone, Conan.
Reply
#2
(08-19-2016, 06:59 PM)conanthewarrior Wrote:  <clip>

I have simply shortened the coil leads on the coils themselves to stop the positive lead from shorting to the tank body. when the lead is too long the device jumps into power mode. I just clip the end of the lead a wee bit and that fixes it.
____
Δ
Join us
Reply
#3
I had this issue with my first 2 battery mod, happened to be one of the original 100w iSticks.
This is what I used to repair it, they are available on Aliexpress.com and there CHEAP!!!
spring loaded DIY 510 Connector.


.jpg   spring510.jpg (Size: 15.11 KB / Downloads: 69)
From a Mind of Metal, Flowing Electrons
Enjoy!

Please Rate...

Register to Download Click Here!
Reply
#4
I am having the same issue with my Cuboid. The unit is several months old and has been used as my all-day mod for most of that time. I have ensured the atomizers I use are not shorted or damaged in any way. I never install an atomizer (whether it is one of my custom builds or a prebuilt assembly from the tank mfr.) before I check it on my meter because I have encountered prebuilt heads that are very far out of spec. For instance, a Kanger CL coil, ni200 at .15 ohm, the coil actually read .62ohms on my meter so it was unusable.

I have a variety of RDAs and RTAs in addition to an eGo ONE Mega tank that came with my eVic VT. Using Joyetech replacement coils that are measured, verified, and tested on my other mods, I consistently get the 'atomizer short' error on the Cuboid.

I have upgraded and downgraded firmwares to see if that had an effect, to no avail. Different atomizers (ALL tested on other working units and proven to be within correct specs such as wire type, resistance, coil size, coil position, and number of wraps) all exhibit the same error condition regardless of the specifics of the build. I can sometimes back the atomizer off until I get "No Atomizer Found", wiggle the atomizer gently in the 510 socket then, while the display is still illuminated, I tighten the atomizer until it first reads the resistance. I know if the resistance reads higher than the actual value by more than .05 or .06 ohms, I will get the atomizer short error. If the resistance reads within .05 ohms of the actual value, I can successfully fire the atomizer, sometimes one firing, sometimes all day. So the issue is intermittent in that aspect.

Is there anything that can be done for this because I love the mod and would hate to have to send it to the junk pile.
Reply
#5
Sounds like my Cuboid, it comes with defective ohm reader. In my case I started to notice it after two months of use. At first the value was like +0.05 to +0.09 and now after more than a year it gets worst +0.15 to +0.19 and ever since its impossible to use any Temp Mode. I have Ohm meter, evic vtc mini, even tried my atty to other Cuboid all reads the same except my device. That's why we need features that we can manually detect the resistance and forcefully manually set it like most newer device in the market.

I think auto features is good but not in most cases because we as humans with brains knew better than a brain less device.
Reply


Bookmarks

Forum Jump:


Users browsing this thread: 1 Guest(s)