Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Temp Control power is jumping up to 30W
#1
Hi all,

I'm using SS316 mode with temp control and I have set the Power to 10W-15W and 200Celsius. The problem is when I'm vaping- pushing the fire button, the power jump up to 30W. So the control doesn't work and my cotton is burned all the time. I asked several people but nobody knows the solution.. Only thing what I have found, I need to go around few times in the menu and after that switch back to TC mode and it keep the 10W boundary.

Any solution? //firmware 3.02 (downgraded from 03), with taifun GT2. It worked several month, so nothing changed during this time..

Thanks in advance!

A
Reply
#2
Your coil is not being recognised as a TC coil and the Evic is defaulting to 30 watts in power mode.

Have you recently recoiled it? Did you do something different with the coil? What are the specs of the coil?
“Giving up smoking is the easiest thing in the world. I know because I've done it thousands of times.”  - Mark Twain
Reply
#3
(08-12-2016, 06:27 AM)louiesquared Wrote:  Your coil is not being recognised as a TC coil and the Evic is defaulting to 30 watts in power mode.

Have you recently recoiled it? Did you do something different with the coil? What are the specs of the coil?

Thanks for your answer. SS 0.28, coil diameter: 2.5mm, lenght: approx. 2.5-3 mm (4-5 wraps)

Nope, I didn't do any different with the coil and yes, I recoiled it several times. I got your point, my coil is not being recognised, but the strange thing, after several round in the menu, it is recognized. strange...
Reply
#4
I recommend using 5 - 7 wraps.
Reply
#5
(08-12-2016, 06:51 AM)arena Wrote:  
(08-12-2016, 06:27 AM)louiesquared Wrote:  Your coil is not being recognised as a TC coil and the Evic is defaulting to 30 watts in power mode.

Have you recently recoiled it? Did you do something different with the coil? What are the specs of the coil?

Thanks for your answer. SS 0.28, coil diameter: 2.5mm, lenght: approx. 2.5-3 mm (4-5 wraps)

Nope, I didn't do any different with the coil and yes, I recoiled it several times. I got your point, my coil is not being recognised, but the strange thing, after several round in the menu, it is recognized. strange...

Is it a spaced coil?

Make sure that all of the connections are secure. A loose connection will cause resistance issues which can cause TC errors.
“Giving up smoking is the easiest thing in the world. I know because I've done it thousands of times.”  - Mark Twain
Reply
#6
(08-12-2016, 08:16 AM)louiesquared Wrote:  
(08-12-2016, 06:51 AM)arena Wrote:  
(08-12-2016, 06:27 AM)louiesquared Wrote:  Your coil is not being recognised as a TC coil and the Evic is defaulting to 30 watts in power mode.

Have you recently recoiled it? Did you do something different with the coil? What are the specs of the coil?

Thanks for your answer. SS 0.28, coil diameter: 2.5mm, lenght: approx. 2.5-3 mm (4-5 wraps)

Nope, I didn't do any different with the coil and yes, I recoiled it several times. I got your point, my coil is not being recognised, but the strange thing, after several round in the menu, it is recognized. strange...

Is it a spaced coil?

Make sure that all of the connections are secure. A loose connection will cause resistance issues which can cause TC errors.

Can you be more specific? What do you mean regarding the secure coil? Actually, I have never used spaced coil. There is no space between my wraps.
Reply
#7
He meant that you coils does make proper contact anymore somewhere along the way. Check all the way down from the wire posts to the 510.
Reply


Bookmarks

Forum Jump:


Users browsing this thread: 2 Guest(s)