Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Cuboid 150W Honest Review
coil? ohms? wattage or temp?
This instrument is a complete monster
I was very pleased with it, worked amazing. I thought i'd update the software on the unit, totally not what i should have done. I should have thrown it out the window. After i updated it, the unit started heating up in my pocket to were i wasn't even able to hold it in my hand. for no reason, the display started flashing and flickering. as of the other day it will no longer turn on or show any kinda of display. The computer will recognize it. but no display, its not in "stealth mode" as some say. i've watched hours upon hour upon hours of videos and read thread and forums. trying to figure this out and nothing. I decided finally to spend extra money and buy something worth having and would last me a while, which has totally failed me and so disappointed. it last 2 months. if that. I read so much about Joytech before i bought it. Saw so many great reviews and people saying amazing things.

This Cuboid 150W has failed my expectations and extremely disappointed. I'm lost for words.   嗯  生气  无法决定  无法决定  嗯  嗯  嗯  嗯  嗯  
(06-27-2016, 02:35 AM)Dissapointed Wrote:  There are no known reliable fixes for this issue.

My first mod was an iStick mini. It worked great with the Aspire K-1 I bought at the same time but when I switched to an Aspire Nautilus mini the connector was too long. The tank would not sit flush on the mod so I made a washer from a can lid that filled the gap. It was easy to do and has been extremely reliable. It is simply a matter of measuring the gap with a feeler gauge and then fabricating a washer out of sheet metal that is that thickness or a tiny bit thicker. After fitting the washer I have had no problems with the vaporizer at all and I often forget the washer is there until I remove the tank. It is kind of strange that these kind of adapter washers are not more readily available.


Forum Jump:

Users browsing this thread: 1 Guest(s)