Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
"weak Battery" flashing above 60 watts
#1
Hello there. I am having issues with my Vtc mini. When I set the temp to 60 watts or more, I get a "weak battery" sign on the Lcd, and it will fire in the 50 watt range instead of what it's set at. I'm using a Cleto tank. New to this, so I'm unsure why it does this. I had my Cleto on a smaller Pico and always cranked at 70 watts with no issues. My firmware is updated as well. Is anyone else having this issue?
Reply
#2
@Djreact33

Did you use the same 18650 battery for two devices?
Reply
#3
The most important question are:
- what battery is that?
- how old?
- what coil and which ohm value are you using?

(BTW. Just thinking, why is it for almost every problem posted here there are incomplete information provided and giving answers impossible? Please, no personal offenece intended.)
Reply
#4
The VTC Mini demands a strong battery some brands like Efest just wont cut it for this device.
I run AWT 40A 3000mah batteries they preform well and great for me because there locally available.
not all 18650's are equal so do a bit of comparing and find yourself a good one.
From a Mind of Metal, Flowing Electrons
Enjoy!

Please Rate...

Register to Download Click Here!
Reply
#5
(06-13-2016, 12:42 PM)Axleofevil Wrote:  The VTC Mini demands a strong battery some brands like Efest just wont cut it for this device.
I run AWT 40A 3000mah batteries they preform well and great for me because there locally available.
not all 18650's are equal so do a bit of comparing and find yourself a good one.

Thank you. I will try a different battery.

(06-13-2016, 12:32 PM)peter-k Wrote:  The most important question are:
- what battery is that?
- how old?
- what coil and which ohm value are you using?

(BTW. Just thinking, why is it for almost every problem posted here there are incomplete information provided and giving answers impossible? Please, no personal offenece intended.)


I guess You missed the whole "new to vaping" part, jerkoff.
Reply
#6
Not, was just thinking you have been sold / bought wrong batteries for your setup and tried to help.
Reply


Bookmarks

Forum Jump:


Users browsing this thread: 1 Guest(s)