Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Cuboid displaying atomizer short
#1
hi, i just recently purchased the cuboid mod and was excited about using it. When it arrived i tested it on my zephyrus v2 tank and it kept displaying atomizer short on the led screen. I could not get it to work but i tried a subtank mini on it it worked. Any solutions to solve this issue? i read online that it seems to be the 510 connector or insulator issue
Reply
#2
(03-24-2016, 11:17 AM)kishino Wrote:  hi, i just recently purchased the cuboid mod and was excited about using it. When it arrived i tested it on my zephyrus v2 tank and it kept displaying atomizer short on the led screen. I could not get it to work but i tried a subtank mini on it it worked. Any solutions to solve this issue? i read online that it seems to be the 510 connector or insulator issue

are you using the RBA Build Deck in the zephyrus? if you are it could be what is causing the short. does the zephyrus work on any other mod?
Reply
#3
(03-24-2016, 11:37 AM)bey1012 Wrote:  
(03-24-2016, 11:17 AM)kishino Wrote:  hi, i just recently purchased the cuboid mod and was excited about using it. When it arrived i tested it on my zephyrus v2 tank and it kept displaying atomizer short on the led screen. I could not get it to work but i tried a subtank mini on it it worked. Any solutions to solve this issue? i read online that it seems to be the 510 connector or insulator issue

are you using the RBA Build Deck in the zephyrus? if you are it could be what is causing the short. does the zephyrus work on any other mod?

yes i am using the RBA deck in the zephyrus. it worked with my subox mod though. any way to make it work on cuboid?
Reply
#4
@kishino

What coil value you premade and which kind of coil, clapton? How long would it cut off and display "atomzier short"?
We have real time borad pretction during firing, when device detected the ohn valude decreased to a certain range, it will cut off power output. Othweise, you can imagine when real short happens, the device is easily got damaged.
Reply
#5
i made a kanthal dual coil of 0.5ohms .it would not detect the atomizer at all when i connected the tank to the mod. it displays 0 ohms.
Reply
#6
(03-24-2016, 04:50 PM)kishino Wrote:  i made a kanthal dual coil of 0.5ohms .it would not detect the atomizer at all when i connected the tank to the mod. it displays 0 ohms.

Can you make coil photo here for further checking? If the coil loops are get close each other, it gets short.
Reply
#7
(03-24-2016, 04:50 PM)kishino Wrote:  i made a kanthal dual coil of 0.5ohms .it would not detect the atomizer at all when i connected the tank to the mod. it displays 0 ohms.

It reay sounds like your getting a short from the coils you made I have had it happen with a simular tank I would just check the coil and make shure it is not touching the post and tighten the screws and if none of that works it might be the 510 connection also you could try putting a premade coil in the tank to see if it shorts
Reply
#8
Had the same Issue with Claptons on the Griffin RDA and the Cuboid, but since i used standart Stainless Steel (316L) Coils it works like a charm.

I used the UD Clapton Wire, and i think this Wire isnt the best at all.
Reply
#9
(03-24-2016, 11:17 AM)kishino Wrote:  hi, i just recently purchased the cuboid mod and was excited about using it. When it arrived i tested it on my zephyrus v2 tank and it kept displaying atomizer short on the led screen. I could not get it to work but i tried a subtank mini on it it worked. Any solutions to solve this issue? i read online that it seems to be the 510 connector or insulator issue

Did you ever find a solution to this? I'm having the same problem and was hoping to find out what was going on
Reply
#10
(04-20-2016, 04:14 AM)MDubYaK Wrote:  Did you ever find a solution to this? I'm having the same problem and was hoping to find out what was going on
The problem comes from the <insert preferred swearword here> 510 which is used for the cuboid. If the 510 of your atomizer is slightly longer than 4.6 mm you will have "atomizer short".
Joyetech say "Oh, the solution is easy, just use Joyetech atomizers, and you will have no problems".
(Where is the facepalm smilie?)

@Joyetech: What do you think about using real spring loaded 510 connectors for the next generation of mod boxes?
I am willing to pay the 50 cent more, which a good connector will increase your production costs.
Reply


Bookmarks

Forum Jump:


Users browsing this thread: 1 Guest(s)