Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Cuboid display problem
#11
I have tried that and it still doesn't work, I keep getting the USB device not recognized message over and over again
Reply
#12
(04-06-2016, 05:14 AM)andreg Wrote:  I have tried that and it still doesn't work, I keep getting the USB device not recognized message over and over again

Please contact service@joyetech.com looking for after-sales supports. I think your device got other display problems.
Reply
#13
Hi Guys,
I have the same issue on my Cuboid ss. After removing it on the box and made changes on the settings all went fine but after several minutes of Idle and when you click any of the buttons there's no display on the screen. You need no remove the battery and reinserted to the unit just to show display on the screen. I tried to upgrade the firmware but the problem still exist.
Reply
#14
(06-07-2016, 10:05 AM)rscastil Wrote:  Hi Guys,
  I have the same issue on my Cuboid ss. After removing it on the box and made changes on the settings all went fine but after several minutes of Idle and when you click any of the buttons there's not display on the screen. You need no remove the battery and reinserted to the unit just to show display on the screen. I tried to upgrade the firmware but the problem still exist.

Hi, perhaps your screen had problems.

(06-07-2016, 10:05 AM)rscastil Wrote:  Hi Guys,
  I have the same issue on my Cuboid ss. After removing it on the box and made changes on the settings all went fine but after several minutes of Idle and when you click any of the buttons there's not display on the screen. You need no remove the battery and reinserted to the unit just to show display on the screen. I tried to upgrade the firmware but the problem still exist.

Hi, perhaps your screen had problems.
Reply
#15
(06-07-2016, 03:18 PM)vapormaker Wrote:  
(06-07-2016, 10:05 AM)rscastil Wrote:  Hi Guys,
  I have the same issue on my Cuboid ss. After removing it on the box and made changes on the settings all went fine but after several minutes of Idle and when you click any of the buttons there's not display on the screen. You need no remove the battery and reinserted to the unit just to show display on the screen. I tried to upgrade the firmware but the problem still exist.

Hi, perhaps your screen had problems.


(06-07-2016, 10:05 AM)rscastil Wrote:  Hi Guys,
  I have the same issue on my Cuboid ss. After removing it on the box and made changes on the settings all went fine but after several minutes of Idle and when you click any of the buttons there's not display on the screen. You need no remove the battery and reinserted to the unit just to show display on the screen. I tried to upgrade the firmware but the problem still exist.

Hi, perhaps your screen had problems.

Screen problem? So why it is only happen when the unit is Idle for a 5 minutes or more?
Reply
#16
Dear,

I have the same problems as Xtra.

Now I put the unit to lock using pressing 5 times the fire button now when unlocking but pressing the fire button the unit unlocks but the display stays off and can’t be turned on.
I have tried playing with stealth mode etc. also tried the firmware upgrade from the Joyetech website.
When the screen is off even plugin the USB cable will not show the "battery indicators"

Cuboid also starts warming up when he is turned off.


GRtz
Reply
#17
(07-01-2016, 11:46 PM)EneleX Wrote:  Dear,

I have the same problems as Xtra.

Now I put the unit to lock using pressing 5 times the fire button now when unlocking but pressing the fire button the unit unlocks but the display stays off and can’t be turned on.
I have tried playing with stealth mode etc. also tried the firmware upgrade from the Joyetech website.
When the screen is off even plugin the USB cable will not show the "battery indicators"

Cuboid also starts warming up when he is turned off.


GRtz

I'm having exactly the same problems and I've only had my Cuboid for 2 months, anyone got any troubleshoots for us?
Reply
#18
(07-01-2016, 11:46 PM)EneleX Wrote:  snip ...
Cuboid also starts warming up when he is turned off.

GRtz

In another thread we have learned a Cuboid which is warming up while in off mode is probably having a pair not matched batteries. The one battery is trying to charge the other one.
Reply
#19
i have this problem too with cuboid but instead the screen flashes when i connect it to pc i have tryed to reflash the firmware but it didnt work can anyone help me? 无法决定  无法决定  无法决定  无法决定
Reply
#20
(02-16-2016, 10:44 AM)Kermit Wrote:  
(02-13-2016, 03:38 AM)Xtra Wrote:  I received the Cuboid today  but unfortunately  , the unit isn’t working correctly.

The problem is as follows:
I have put fully charge batteries (LG 30A)  in the unit and made some setting, so far everything fine.
Now I put the unit to lock using pressing 5 times the fire button now when unlocking but pressing the fire button the unit unlocks but the display stays off and can’t be turned on.
I have tried playing with stealth mode etc. also tried the firmware upgrade from the Joyetech website, then the display turns on.
But when locking it again the problem occurs again.
When the screen is off even plugin the USB cable will not show the "battery indicators"

So this unit can’t really be used as the only way of finding whether the unit is turn on is by pressing the fire button until I can hear the coil heating.

I did try upgrade and downgrade the firmware via the firmware tool but so far no succes.

Dear Xtra, sorry for the trouble. Kindly please send me the S/N and security code via email (kermit.li@joyetech.com). We'll check then.


I've also had this issue with the cuboid as well. I'm stumped i've tried everything i can think of.
Reply


Bookmarks

Forum Jump:


Users browsing this thread: 1 Guest(s)