Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Evic vtc mini not working after software upgrade
#1
Hi, my evic vtc mini doesnt work anymore after i did the software upgrade. When i plugged it in my computer the screen dont display anything. Even with or without batteries it does not open. Can some body help me? Thanks.
Reply
#2
hey, did you successfully upgrade or it happened during upgrading?
Reply
#3
Your upgrade was unsuccessful. Did you pull the USB plug half way through upgrading? You need to redo the upgrade again.

心JOYETECH - NO:1 Ecig brand 心
Reply
#4
Remove atomiser too, if you have not tried that already
Reply
#5
I have 3 evic mini vtc and upgraded all to the new 2.0. All but one works great. The one that doesn't work correct has a dimmer screen then the others and when I hit the button to vape I'm getting a "weak battery" message although I have a full battery. It also cuts off if I leave it unattended for over 3 minutes. I have to plug it up to get it to cut back on. It's even given me a "no atomizer" message. This issue did not happen until updated from the previous version and it's only this device. I've used the ego one mega velocity and crown tank, and I've tried several different batteries still same problem. Just now I decided to just downgrade back to the previous version, now my computer it was reading "USB DEVICE NOT RECOGNIZE" so now I can't even conect it to my computer to do anything with device. And just to make sure it wasn't my computer or the cord I plugged my other two Evic Vtc's into my computer, both connect with no problem. I've used different cakes and usb inputs on my computer; now my computer isn't even reconizing it when plugged it. Anyone else who is having this issue please help, I'm lost and very unhappy. Glad I do have more then one but still upset my evic is barely usable. Also this wasn't my first time upgrading my evic vtc's.
Reply
#6
Try rebooting your computer.
Did you download the firmware from Joyetech?
If it still fails try another computer.

Good luck

心JOYETECH - NO:1 Ecig brand 心
Reply
#7
(11-10-2015, 05:31 AM)TAYLORGANGVAPOR Wrote:  I have 3 evic mini vtc and upgraded all to the new 2.0. All but one works great. The one that doesn't work correct has a dimmer screen then the others and when I hit the button to vape I'm getting a "weak battery" message although I have a full battery. It also cuts off if I leave it unattended for over 3 minutes. I have to plug it up to get it to cut back on. It's even given me a "no atomizer" message. This issue did not happen until updated from the previous version and it's only this device. I've used the ego one mega velocity and crown tank, and I've tried several different batteries still same problem. Just now I decided to just downgrade back to the previous version, now my computer it was reading "USB DEVICE NOT RECOGNIZE" so now I can't even conect it to my computer to do anything with device. And just to make sure it wasn't my computer or the cord I plugged my other two Evic Vtc's into my computer, both connect with no problem. I've used different cakes and usb inputs on my computer; now my computer isn't even reconizing it when plugged it. Anyone else who is having this issue please help, I'm lost and very unhappy. Glad I do have more then one but still upset my evic is barely usable. Also this wasn't my first time upgrading my evic vtc's.

Kindly please try other cords and redo the upgrading.
Reply
#8
I've tried everything still no luck it's only this device my other two Evic vtc work connect and function perfect.
Reply
#9
问题 
hi..i have the same problem too but not because of upgrading. i modified my vtc mini using nfirmwareeditor..maybe its because of some installed patches. the problem is my computer cant detect my mod so i couldnt reset it with the original joyetech bin file..tried another pc but still same problem..please help me  悲伤


Attached Files Thumbnail(s)
   
Reply
#10
When this has happened to me the software still sees my device, i just re-flash the firmware or just change the custom logo and the display comes right back. in your case it may be different but you are getting some connection I see windows sees an unrecognized device hooked to your pc. Pull your battery and tank and hook it up again see if then the software sees the device. If still no, try Vapor maker has a more extensive solution on his thread http://social.joyetech.com/showthread.php?tid=2701 and he has an attachment that tries to explain if the device is bricked to follow his steps in an attachment to his message http://social.joyetech.com/attachment.php?aid=700 .
good luck, don't give up, you will find a solution.

I would try closing everything, restart PC remove battery and tank, start just firmware update software, hook device to USB, see if software sees device, if not try Vapormakers suggestions
Reply


Bookmarks

Forum Jump:


Users browsing this thread: 1 Guest(s)