Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Evic AIO Blinking Display and Nonresponsive
I bought an Evic AIO from a local shop a week ago. I have already had to go through 3 of the replacement coils it came with to solve its spitting problem, but since the last coil I tried I haven't had any issues with the spitting.

The real problem is as follows:
Yesterday morning, I took it off the charger where it had been all night. The display was blinking alternately "Key Lock" and "Key Unlock" even though I had never locked (or unlocked) it before. I could not get the vape to respond to anything - the fire button did not work. If I hold it down for a few seconds, it will turn stealth mode on or off. I cannot turn the vape off and the temp adjust buttons are both nonresponsive - they neither lock nor unlock the device. The problem remedied itself by mid-afternoon yesterday, so I took the thing to the shop where I bought it, and the man couldn't give me any conclusive answers on what had been happening.

Today, the vape did the same thing, except that it did not become unresponsive right after I put it on the charger - it was about 1:00 today when it started doing exactly the same thing as yesterday. It had a full charge in the morning, as it had been on the charger all night.

I have tried everything I can think of (turning vape off, cleaning vape, removing and replacing battery, putting it back on charger, pressing/holding every combination of temp adjust button) and the representative from Joyetech I'm e-mailing right now keeps telling me to try things I've already told her I tried.

Please help!!


Forum Jump:

Users browsing this thread: 1 Guest(s)