Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
eVic VTo Mini Temperature Control SS wire problems

I am experiencing an issue with my eVic VTwo Mini that I bought recently.
I cannot make the Temperature Mode work correctly.
I am using Stainless Steel 316 wire, an I have also tried with Ni wire.
Everything seems set correctly, the atomizer is detected and Ohms are correct, I set the desired temperature and wattage that I wish to use in Temp mode. But when I press the fire button, the evic fires and on the screen its constant 21Celsius and the wattage is set at 30watts. It basically just fires at 30watts, regardless of the atomizer or coil I have or setting in Temp menu.
As soon as I press the button it ignores my settings. I have looked at the screen while puffing and the temperature displayed apparently rises somewhat occasionally while I inhale but 90 percent of the time it just shows 21C and fixed 30wats when I press the fire button. I have tried ever possible thing I could think of, every setting, it just doesn't seem to work any way other than what I have described 悲伤
I was really looking forward to using this mode, thats one of the reasons I bought this eVic. My firmware is V4.02.

Please help me if you have any advice or suggestion or know why is this happening and how to make it work.

Thank you


Messages In This Thread
eVic VTo Mini Temperature Control SS wire problems - grahams - 06-01-2017, 01:01 AM

Forum Jump:

Users browsing this thread: 1 Guest(s)