Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Evic AIO Blinking Display and Nonresponsive
Alright so to preface, I've had this entire box setup for a week exactly now.
My problems began with the coils - the vape had been spitting ejuice through the mouthpiece. After trying the last of my 4 replacement coils, I found one that works and I haven't had any trouble with the vape spitting.

Yesterday morning, after having had it on the charger all night, I could not get it to respond to any prompts. The screen alternately blinked "Key Lock" and "Key Unlock", though I had never before locked (or unlocked) it. I tried everything I could think of(pressing both temp adjust buttons, holding both temp adjust buttons, pressing fire button 5x, holding fire button down, removing and replacing battery)The problem persisted until the mid-afternoon, when it fixed itself without my doing anything. I went to the shop where I bought it, and the man who helped me didn't seem to know what the problem had been.

Today, it did the same thing, only it didn't happen directly after I took it off the charger. It charged all last night, then was fine until about mid-afternoon today, when it started blinking. I tried everything again, and cannot get it to fire, turn off, or do anything but alternately blink "Key lock" and "Key unlock".

E-mails to Joyetech have been slow and not helpful- they keep telling me to try things I have told them I've already tried

Please help!!


Messages In This Thread
Evic AIO Blinking Display and Nonresponsive - skelletope - 03-02-2017, 07:41 AM

Forum Jump:

Users browsing this thread: 1 Guest(s)