Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Again - TCR changes to Power Mode
Hi guys, sorry if this been asked so many time here.
Been reading all those threads but still no clue

Here's my gear:
Cuboid 150 ver 5.14
RDTA Avocado 24
Dual DIY vertical coil, SS316L 0.18 ohm
TCR mode 92, 430 F, 55 watts
Battery 2x Sony VTC6
Wick : cotton to the bottom of the tank
Airvent all open

I've been using cuboid (1st time vaper) for almost a week now. Its a great and cool looking mod.
The problem is that everytime i open my tank for refilling juice, the TCR mode always switch to 20watts power mode.
What i've done so far are:
- turn off the mod
- unlock the ohm sign
- take off the tank and plug it back
- wipe the mod-tank connector
- take off the batteries
- use power mode for a while then switch back to TCR mode
- change the TCR value
- wipe all the inside of the coil chamber
- change the liquid

Sometime it works and i can use the TCR mode again, but mostly it won't work
My question is:
1. Is there something that i've been doing it wrong?
2. How to prevent this happening again?
3. Can someone give a good setting for great vapor using single  SS316L  wire? (Ohm, watt & wraps that I should aim for)

Thanks a ton
This sounds like you have a loose connection on your coils. Try tightening everything up again.
“Giving up smoking is the easiest thing in the world. I know because I've done it thousands of times.”  - Mark Twain
(09-26-2016, 11:58 PM)louiesquared Wrote:  This sounds like you have a loose connection on your coils. Try tightening everything up again.

I've checked that, the coils are tight
I notice that the base ressistance not that accurate
Few things I noticed when this happened to me:

Swapping to a different brand of SS316 might help.
I had some SS316 from FT and this did not play nicely with the Cuboid. Picked a different brand of SS316 from FT again, which worked fine.
Later on I used the troubled wire with a manually set coefficient TC without issues. Guess it wasn't as 316 as the label claimed.
You'll prob also note the temp not reaching it's limit (easily). Either how, if you only used one type/brand of SS, worth to try some other brand.
No need to buy the expensive hyped stuff btw. The black&white labelled cheap stuff from FT works for me and costs next to nothing p/ft.

Once the center screw of my atty wasn't tightened anymore, causing incorrect resistance read.
(keep in mind, the changes are very tiny and slight imperfections in connection can has 'massive' impact)
Take your atty apart completely, clean it thoroughly and put it back together properly and tighten everything down.

And lastly, cleaning the 510 connector with a cotton bud and some alcohol or nail polish remover might help as well.


Sounds like my Cuboid, it comes with defective ohm reader. In my case I started to notice it after two months of use. When I first noticed it was like +0.05 to +0.09 and now after more than a year it gets worst +0.15 to +0.19 and ever since its impossible to use any Temp Mode. I have Ohm meter, evic vtc mini, even tried my atty to other Cuboid all reads the same except my device. Thats why we need features that we can manually detect the resistance and forcefully manually set it like most newer device in the market. Fortunately it seems Cuboid ignores the resistance in Power Mode. I get the same amount of vapor on same setting with my Evic VTC Mini.

I think auto features is good but not in most cases because we as humans with brains knew better than a brain less device.

Please Joyetech do something let us set resistance manually.


Forum Jump:

Users browsing this thread: 1 Guest(s)