Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Evic VTC mini charging? Or not?
Hi guys.

Hope you can help. I have an evic vtc mini with latest firmware update. I dont have an external battery charger (although its on my priority list), so im using the usb charging port in the MOD itself. For the first 3 months.... no problem at all. Now all of a sudden, whenever I plug my charger (the same one ive always been using) into the MOD, it doesnt show any kind of charging status/indicator. It always used to.

However... here comes the weird part... At first I thought the port was broken and wasnt charging. But it appears as if it is. In other words, when i put it on charge nothing happens in terms of showing charging progress/status. But if i leave it plugged in (on a completely blank screen) for long enough, the battery comes out charged. I get the same result if i use different batteries and/or different charging cables.

So ultimately... the whole unit is still operational and appears to still be charging. But it doesnt show me visually that it is on charge and successfully charging.

Anyone have a similar issue or know what is going on?

Thanks in advance!
Try one of the patched firmwares found HERE in my beyond logos thread. These firmwares have a unique charge screens I'm curious if you would still not see it.
From a Mind of Metal, Flowing Electrons

Please Rate...

Register to Download Click Here!


Forum Jump:

Users browsing this thread: 1 Guest(s)