Joyetech Social

Full Version: Refusal to Honor Warranty of brand new eGo ONE v2 by service@joyetech.com
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I recently purchased an eGo ONE V2 directly from the Joyetech US online store. (I figured that would be the best way to ensure that I got the genuine product and not a clone.)

I read the instructions, charged the battery, primed the coils, loaded store bought e-juice, and tried to vape.

Every attempt to use it results in hissing, popping, and very high temperature output. The metal mouthpiece becomes almost hot enough to cause burns; and even with the plastic mouthpiece the output is HOT. No combination of settings or coils results in proper function. It is like neither regulation method is doing anything more than passing the full battery voltage directly to the coil.

I immediately contacted customer service.
Fourteen business days and twenty emails have resulted in neither refund nor product replacement.

Can anyone suggest a source of help; or have I just been cheated out of forty dollars?

Ken
I had exactly the same problem Today. The Mouthpiece is getting extremely hot even with low Temp and Watt. I contact the support and still waiting response. Also did a post here to see if I get any support.

I am using the new eVic VTwo with CUBIS Pro.
Turn the settings down, be sure your not in Celsius when you want Fahrenheit. Start low and slowly work your way up.
Joyetech will return your emails soon, they are just a little slow, but they will honour their warranty if it is a defective device, but to be honest it sounds like user error, turn it down!
Did you try lower settings, Ken? I gather you did already try all kind of settings combinations.
(08-30-2016, 12:24 PM)peter-k Wrote: [ -> ]Did you try lower settings, Ken? I gather you did already try all kind of settings combinations.

Peter:

The eGo ONE V2 has no setting adjustments.

It has two modes.
Direct output mode (white light) and
Constant voltage output mode (orange light)

Both modes appear to do nothing more than pass the battery voltage directly through to the coils.

"Hiss - POP - expels tiny droplets of HOT LIQUID.
(08-30-2016, 02:13 PM)Stainless Wrote: [ -> ]Peter:

The eGo ONE V2 has no setting adjustments.
It has two modes.
Direct output mode (white light) and
Constant voltage output mode (orange light)

Both modes appear to do nothing more than pass the battery voltage directly through to the coils.
"Hiss - POP - expels tiny droplets of HOT LIQUID.


Sounds like there is something wrong with the regulatory board.

Sorry to hear about your problems. Joyetech USA might be thinking the same as Cosmic about a user error. Sure someone from the admins here will read your post soon and comment.
(08-30-2016, 07:39 PM)peter-k Wrote: [ -> ]
(08-30-2016, 02:13 PM)Stainless Wrote: [ -> ]Peter:

The eGo ONE V2 has no setting adjustments.
It has two modes.
Direct output mode (white light) and
Constant voltage output mode (orange light)

Both modes appear to do nothing more than pass the battery voltage directly through to the coils.
"Hiss - POP - expels tiny droplets of HOT LIQUID.


Sounds like there is something wrong with the regulatory board.

Sorry to hear about your problems. Joyetech USA might be thinking the same as Cosmic about a user error. Sure someone from the admins here will read your post soon and comment.

That would be great.
(08-31-2016, 02:07 AM)Stainless Wrote: [ -> ]
(08-30-2016, 07:39 PM)peter-k Wrote: [ -> ]
(08-30-2016, 02:13 PM)Stainless Wrote: [ -> ]Peter:

The eGo ONE V2 has no setting adjustments.
It has two modes.
Direct output mode (white light) and
Constant voltage output mode (orange light)

Both modes appear to do nothing more than pass the battery voltage directly through to the coils.
"Hiss - POP - expels tiny droplets of HOT LIQUID.


Sounds like there is something wrong with the regulatory board.

Sorry to hear about your problems. Joyetech USA might be thinking the same as Cosmic about a user error. Sure someone from the admins here will read your post soon and comment.

That would be great.

PM vapormaker and or Kermit, they will assist you with the problem
Strange I just thought about this case then you did this post Mr. Cosmic Alien.

May be Mr. Kermit or Mr. Vapormaker see it this time. It sounds genuine to me.
(09-17-2016, 10:03 AM)peter-k Wrote: [ -> ]Strange I just thought about this case then you did this post Mr. Cosmic Alien.

May be Mr. Kermit or Mr. Vapormaker see it this time. It sounds genuine to me.

Thanks for keeping this thread alive.

My replacement unit arrived on Monday Sept 12.

Same exact ##&#**&# problem.  I guess it is considered impossible for a problem to exist in the design or manufacture of this product.

Tuesday Sept 13th I wrote back to customer service requesting a refund. - Have not heard back yet.

At this point I have written off my $40 and the money I spent to ship back the first defective unit.
Does anyone want it for parts ?  Send me a prepaid shipping package and it is yours.
Pages: 1 2